IPOSPays Portal Login Issues
Resolved
May 10, 2026 at 4:36pm UTC
Resolved – The issue affecting login access to the iPOSPays portal has been resolved.
Users should now be able to successfully log in to portal.ipospays.com without issue. Our engineers have confirmed that the Login button is functioning normally and services have been fully restored.
We appreciate your patience while our team worked to resolve this matter.
Affected services
Created
May 10, 2026 at 4:16pm UTC
Investigating – We are currently aware of an issue affecting access to the iPOSPays portal. Users may experience an issue where the Login button is unresponsive when attempting to sign in.
Our engineering team is actively investigating the issue and working to restore normal functionality as quickly as possible.
We will provide additional updates as more information becomes available.
Affected services